MediaCoder now runs more flawlessly under Wine/Linux (Stanley posted on August 24th, 2008 )

Wine is an open Source implementation of the Windows API on top of X, OpenGL, and Unix/Linux. MediaCoder, as a native Windows application, was able to run under Wine in many cases. Before a native Linux version of the software is developed, the Wine compatibility is improved in build 4180. Now MediaCoder can run more flawlessly on Linux platform. It is no longer necessary to install a Windows version of Firefox under Wine as MediaCoder will look for native Linux Firefox in the Linux system and invoke it to display the XUL-based user interfaces when needed.

The test environment is Gentoo Linux / Xorg / XFCE4 / Wine 1.1. There are known issues under Darwine / Mac OS which might be fixed later. If you still encounter problems under Wine, please report.

Plusone Facebook Twitter Email

COMMENTS: 9 Comments »

TAGS:,

9 Responses

  1. Musaad Haider says:

    Thanks a lot. Its really nice to see developers realizing that their applications should be runnable on Linux to reach a wider audience.

  2. jujuuuuuu says:

    yes .. true. thanks

  3. hugmenot says:

    The image cropper doesn’t work well under wine.

  4. Thomas says:

    Thanks for this.
    When I try to run Mediacoder under Suse 10.2 I get an error 008 (wrong audio codec) no matter which audio codec I choose. Is this a known error?

  5. stanley says:

    Does this occur with the same file and settings under Windows?

  6. Gn0m3r.X says:

    Is it really that difficult to port Mediacoder to Linux?

  7. Gn0m3r.X says:

    Edit: I got it, it’s not completely open source well atleast that’s what wikipedia says

  8. John says:

    Stanley, just want to say thanks for making this work in Linux. Although a native port would be preferable ;) This is by far the easiest way to convert my videos to iPod Touch format. Thank you!